TUD-LaTeX-Forum
http://latex.wcms-file3.tu-dresden.de/phpBB3/

TUD-Script-Klassen: Installationsprobleme
http://latex.wcms-file3.tu-dresden.de/phpBB3/viewtopic.php?f=10&t=351
Seite 2 von 6

Autor:  tudscr [ Montag 2. Juni 2014, 19:55 ]
Betreff des Beitrags:  Re: [tudscr] TUD-Script-Klassen: Installationsprobleme

Hallo Christian,

welche Distribution nutzt er denn? Das Problem ist ja offensichtlich, dass der Befehl 'kpsewhich' nicht gefunden wird. Und dieser wird normalerweise sowohl von MiKTeX als auch Tex Live zur Verfügung gestellt. Ins Blaue getippt vermute ich, dass er eine portable MiKTeX-Version nutzt. Damit habe ich das Skript noch nicht getestet...

Grüße
Falk

Autor:  crau [ Dienstag 3. Juni 2014, 10:22 ]
Betreff des Beitrags:  Re: [tudscr] TUD-Script-Klassen: Installationsprobleme

Hallo Falk,

nee, er nutzt TeX Live 2013. Das Problem war, dass er die bat-Datei einfach durch Doppelklicken ausgeführt hat. Das Ausführen als Administrator hat jedoch den gewünschten Erfolg gebracht.

Gruß
Christian

Autor:  tudscr [ Dienstag 3. Juni 2014, 13:03 ]
Betreff des Beitrags:  Re: [tudscr] TUD-Script-Klassen: Installationsprobleme

Sehr merkwürdig, denn eigentlich sind dafür keine Adminrechte notwendig.

Autor:  JohannesK [ Donnerstag 17. Juli 2014, 19:21 ]
Betreff des Beitrags:  Re: [tudscr] TUD-Script-Klassen: Installationsprobleme

Hallo,
habe leider ein Problem bei der Installation der aktuellen Version. Beim Ausführen der bat-Datei kommt folgender Fehler:

Zitat:
\Users\Johannes\Desktop\TUD-Script_v2.01b_Windows_full\tudscrtemp\conve
rted\lunl8a.afm)
Metrics written on lunl8a.mtx.
! I can't write on file `lunl8a.pl'.
<to be read again>
\xdef
\open_out ...mmediate \openout \out_file =#1\xdef
\out_filename {#1}
\mtxtopl ...ing_global =\x_relax \open_out {#2.pl}
\top_of_pl_hook \out_line ...

\fromafm ...#1}\afmtomtx {#1}{#1}\mtxtopl {#1}{#1}
\fi
\reencodefont #1#2->#2
\resetstr {etx-name}{#1}
\transformfont ... }\x_resetint {slant-scale}{0}#2
\ifisstr {afm-name}\then \...
l.28 ...nl8r}{\reencodefont{8r}{\fromafm{lunl8a}}}

Please type another output file name:

Die alten Klassen habe ich zuvor wie empfohlen deinstalliert. Und auch den Schritt 'initexmf --edit-config-file updmap‘ usw. habe ich ausgeführt, da ich Miktex verwende. Auch das Ausführen als Administrator hat nichts gebracht. Ansonsten habe ich mich bei der Installation an die Dokumentation gehalten.

Schon mal vielen Dank für die Hilfe!
Grüße,
Johannes

Autor:  tudscr [ Freitag 18. Juli 2014, 11:03 ]
Betreff des Beitrags:  Re: [tudscr] TUD-Script-Klassen: Installationsprobleme

Hallo Johannes,

was es nicht alles gibt. Ich dachte echt langsam, dass ich mittlerweile alles erschlagen habe, aber sei's drum. Kannst du mal bitte in der Konsole folgendes ausführen:
Code:
tudscr_v2.01b_full_install.bat > tudscr_v2.01b_full_install.log

Du musst dafür nach der Eingabe zweimal Enter drücken, dabei ca. 1-2 Sekunden Pause lassen. Anschließend hier die Datei tudscr_v2.01b_full_install.log, dann kann ich mir mal das vollständige Log ansehen.

Es sieht so aus, als ob dir gewisse Schreibrechte in dem Ordner fehlen. Hast du mal MiKTeX (bestimmt 2.9 oder?) aktualisiert? Irgendwie ist das alles sehr merkwürdig. Wie gesagt, erstell mir mal ein Log-File, dann sehen wir weiter.

Grüße
Falk

Autor:  JohannesK [ Samstag 19. Juli 2014, 11:26 ]
Betreff des Beitrags:  Re: [tudscr] TUD-Script-Klassen: Installationsprobleme

Hallo Falk,

ich hab dir die log-Datei per Mail (tudscr [at] gmail [dot] com) geschickt, da das Forum log-Dateien als Dateianhang nicht erlaubt...

Viele Grüße
Johannes

Autor:  tudscr [ Samstag 19. Juli 2014, 12:31 ]
Betreff des Beitrags:  Re: [tudscr] TUD-Script-Klassen: Installationsprobleme

Hallo Johannes,

nach dem Durchforsten der log-Datei stellt sich heraus, dass bei der Schriftinstallation der Befehl
Code:
\transformfont{lunl8r}{\reencodefont{8r}{\fromafm{lunl8a}}}
aus dem Paket fontinst nicht richtig ausgeführt werden kann. Dies könnte daran liegen, dass dieses Paket bei dir nicht richtig installiert bzw. veraltet ist. In diesem Fall solltest du dieses Paket über den Paketmanager mal de- und anschließend neu installieren. Ich glaube aber eher nicht daran, weil es ja eher ein Problem nicht vorhandener Schreibrechte ist.

Ich vermute vielmehr, dass es an der von dir verwendeten 64bit-Version von MiKTeX liegt. Diese war bis vor Kurzem noch als Beta-Version gekennzeichnet. Sicher bin ich mir aber nicht, ob es wirklich die Ursache ist. Evtl. findest du ja unter http://sourceforge.net/p/miktex/bugs/ einen Hinweis darauf.

Andernfalls kann ich dir nur noch vorschlagen, die 64bit-Version zu deinstallieren und die 32bit-Variante zu nutzen oder -- meiner Meinung nach die sinnvollere Variante -- gleich auf TeX Live 2014 umzusteigen.

Grüße
Falk

Autor:  rosu6506 [ Donnerstag 14. August 2014, 13:21 ]
Betreff des Beitrags:  Re: [tudscr] TUD-Script-Klassen: Installationsprobleme

Hallo Falk,

unter Win7 und TexLive 2014 bekomme ich folgende Fehlermeldung bei der Installation:

! Transformfont error:
Failed to make transformed font lunl8r;
source font metrics file not found.

Type H <return> for immediate help.
\generic_error ...turn> \space for immediate help}
\endgroup
\transformfont ...cs file not found}\error_help_a
\fi }
l.28 ...nl8r}{\reencodefont{8r}{\fromafm{lunl8a}}}


Log-File habe ich dir an tudscr@gmail.com geschickt.

Wenn ich die Installation weiter laufen lasse kann ich die Minimalbeispiele des Manuals ausführen, allerdings werden die Schriften Univers und DIN-Bold nicht gefunden.

Vom Uni-Marketing habe ich folgende Schriftdateien bekommen:
DINBd__.ttf
Univers Bold.ttf
Univers Light Oblique.ttf
Univers Light.ttf
Univers.ttf

Diese habe ich sortiert als zip gepackt und in den Ordner mit den Installationsdateien gelegt so wie im Manual beschrieben. Fehlen da möglicherweise noch Dateien?

Gruß,
Robert

Autor:  tudscr [ Donnerstag 14. August 2014, 15:21 ]
Betreff des Beitrags:  Re: [tudscr] TUD-Script-Klassen: Installationsprobleme

Hallo Robert,

im Handbuch steht ja nichts davon, dass man sich Univers_PS.zip und DIN_Bd_PS.zip selbst zusammenpacken soll. Diese beiden Archive bekommt man vom Universitätsmarketing, wenn man bei der Schriftbestellung angibt, dass man diese für LaTeX benötigt. Du hast lediglich die OpenType-Schriften jedoch nicht die PostScript-Schriften erhalten. Und mit denen geht es nicht. Also die Schriften einfach noch einmal bestellen, mit dem Hinweis auf die Verwendung für LaTeX. Danach sollte es gehen.

Grüße
Falk

Autor:  rosu6506 [ Freitag 15. August 2014, 09:07 ]
Betreff des Beitrags:  Re: [tudscr] TUD-Script-Klassen: Installationsprobleme

Besten Dank, läuft jetzt!

Gruß,
Robert

Seite 2 von 6 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/