TUD-LaTeX-Forum
http://latex.wcms-file3.tu-dresden.de/phpBB3/

TUD-Script-Klassen: Installationsprobleme
http://latex.wcms-file3.tu-dresden.de/phpBB3/viewtopic.php?f=10&t=351
Seite 4 von 6

Autor:  tudscr [ Mittwoch 25. März 2015, 13:56 ]
Betreff des Beitrags:  Re: TUD-Script-Klassen: Installationsprobleme

Eine letzte Idee: Versuche mal nach dem Abbruch der Installation, über die Kommandozeile im Pfad H:\LaTeX\TUD-Script_fonts_Windows\tudscrtemp\converted den Aufruf latex installfonts.tex. Kommt da die gleiche Fehlermeldung? Eventuell hat LaTeX kein Zugriff auf das Laufwerk H:. In diesem Fall solltest du den Ordner TUD-Script_fonts_Windows mal irgendwohin auf Laufwerk C: (Desktop oder so) kopieren. Geht es dann?

Ich kann dir als Alternative nur vorschlagen, dass du mit deinem Rechner, falls es denn ein Laptop ist, bei mir im Büro vorbeikommst und ich mir die Sache mal anschaue. Ansonsten kann ich dir da, so Leid es mir auch tut, aus der Ferne nicht helfen.

Gruß
Falk

Autor:  Lenny1987 [ Donnerstag 26. März 2015, 16:09 ]
Betreff des Beitrags:  Re: TUD-Script-Klassen: Installationsprobleme

Astrein! Daran lag es... Mit dem Ordner auf nem anderen Laufwerk ist die Installation sauber durchgelaufen... Hätte ich wahrscheinlich auch schonmal früher probieren können - hab ich aber nicht.

Super! Vielen Dank für die Hilfe! Jetzt läuft alles!

Gruß, Lenny

Autor:  tudscr [ Donnerstag 26. März 2015, 16:13 ]
Betreff des Beitrags:  Re: TUD-Script-Klassen: Installationsprobleme

Schön zu hören. Nur aus Interesse: Handelt es sich bei Laufwerk H: um ein externes Laufwerk (USB, externe HDD etc.)? Falls ja, würde ich versuchen, diese Fälle im Skript abzufangen.

Autor:  Lenny1987 [ Montag 30. März 2015, 08:33 ]
Betreff des Beitrags:  Re: TUD-Script-Klassen: Installationsprobleme

Nicht um eine HDD oder USB. Aber um eine separate Partition auf einem Server hier in der Firma... D.h. auf C:/ (also auf dem Rechner an meinem Arbeitsplatz) befindet sich das installierte Latex (MiKTeX 2.9 und TeXStudio), H:/ ist meine "Privatpartition" auf nem zentralen Server.

Gruß

Autor:  tudscr [ Montag 30. März 2015, 22:29 ]
Betreff des Beitrags:  Re: TUD-Script-Klassen: Installationsprobleme

Lenny1987 hat geschrieben:
H:/ ist meine "Privatpartition" auf nem zentralen Server.

Dann leuchtet das Problem auch ein. Dort wird LaTeX nicht so ohne weiteres Schreibrechte haben/bekommen.

Autor:  brunomarx [ Freitag 31. Juli 2015, 23:29 ]
Betreff des Beitrags:  Re: TUD-Script-Klassen: Installationsprobleme

Hallo,

ich versuche seit Tagen die Schriften zu installieren uns es klappt überhaupt nicht.

Ich benutze Ubuntu 14.04 LTS und habe TexLive über Kommandozeile(tar.gz entpackt und .sh ausgeführt) installiert. Nach 45 Minuten war die Installation fertig. Anschließend versuchte ich, ein Minimalbeispiel zu kompilieren.

Fehldermeldung: Package hyphsubst Error: Unknown pattern ngerman-x-latest

Ich dachte, das Komma-Skript ist schon enthalten. Ich musste nur noch die Schriften installieren.
Wie in der Anleitung hatte ich alle Dateien in einem Ordner.

beim Ausführen des Skripts zur Installation der Schriften taucht folgendes auf:

Das Latex-Paket iwona (iwona.sty) wurde nicht gefunden...
Bitte dieses Paket über die Distribution installieren.

Das betraf auch andere Pakete, obwohl sie in TexLive mit dabei sind.


Ich dachte, ich kann sie über Ubuntu Software Center installieren.
hab das getan und wolte das Skript wieder ausführen.

neuer Fehler aufgetaucht:

!pdfTeX error: pdflatex.exe (file lunl8r): Font lunl8r at 526 not found

Danach wusste ich nicht mehr, was ich tun sollte.
Jemande eine Idee?

Grüße

Bruno

Autor:  tudscr [ Sonntag 2. August 2015, 14:40 ]
Betreff des Beitrags:  Re: TUD-Script-Klassen: Installationsprobleme

Hallo Bruno,

ich werde mal versuchen, ein wenig die Glaskugel zu lesen. Sowohl der FehlerPackage hyphsubst Error: Unknown pattern ngerman-x-latest beim Kompilieren als auch die Fehlermeldung Das Latex-Paket iwona (iwona.sty) wurde nicht gefunden... beim Installieren der Schriften deutet darauf hin, dass bei der Installation von Tex Live irgendwas schiefgelaufen ist. Was genau, kann ich allerdings nur schwerlich sagen. Ich kann die lediglich sagen, dass das Installationsskript mit beispielsweise kpsewhich iwona.sty nach den benötigten LaTeX-Paketen sucht.

Wenn du dann allerdings über das Ubuntu Software Center bestimmte Pakete noch nachinstalliert hast, dann schwirren sehr wahrscheinlich mittlerweile zwei Tex Live Installationen auf deinem System rum. Und dann wird's richtig Murks.

Damit ich dir weiterhelfen kann, brauche ich sowohl ein log-File der Schriftinstallation als auch ein Log-File von einem Minimalbeispiel.

Grüße
Falk

Autor:  brunomarx [ Montag 3. August 2015, 10:22 ]
Betreff des Beitrags:  Re: TUD-Script-Klassen: Installationsprobleme

Hallo Falk,

ich konnte nicht mehr durchblicken, als ich die vorherige Nachricht geschrieben habe. Gestern habe ich das Betriebsystem neu aufgesetzt und wieder Texlive installiert. Es handelt sich dabei um eine Vollinstallation. Danach habe ich versucht, ein Minimalbeispiel zu kompilieren. Es ging. Kein Fehler hat diesmal die Erstellung von der PDF-Datei gehindert. Allerdings taucht die Fehlermeldung auf:

Class tudscrreprt Warning: `Univers' fonts not found for encoding `T1'.
(tudscrreprt) Please use one of the installation scripts for the
(tudscrreprt) tudscr-bundle mentioned in the manual.
(tudscrreprt) A fallback layout is used.

Dann habe ich versucht die Schriften zu installieren. Es hat leider nicht geklappt, denn eine andere Fehlermeldung tritt auf:

! Transformfont error:
Failed to make transformed font lunl8r;
source font metrics file not found.


Ich habe zwei Log-Dateien angehägt:
Einmal für die Installation der Schriften und einmal für das Minimalbeispiel(Dokument)


Danke für die Hilfe!


Viele Grüße

Bruno

Dateianhänge:
bruno.log [35.15 KiB]
291-mal heruntergeladen
tudscr_fonts_install.log [151.55 KiB]
312-mal heruntergeladen

Autor:  tudscr [ Montag 3. August 2015, 11:03 ]
Betreff des Beitrags:  Re: TUD-Script-Klassen: Installationsprobleme

Hallo Bruno,

kann es vielleicht sein, dass du die Archive für die Schriften umbenannt hast? Das Log-File deutet stark darauf hin, dass du eigentlich die Dateien UNIVERS_8_TTF.zip und DIN_TTF.zip erhalten und einfach umbenannt hast. Dann kann die Installation auch nicht klappen. Bestelle -- wie von mir sowohl im Handbuch als auch bei GitHub und hier im Forum explizit angegeben -- beim Universitätsmarketing die Schriften für LaTeX und dann sollte es auch funktionieren.

Grüße
Falk

Autor:  brunomarx [ Montag 3. August 2015, 11:44 ]
Betreff des Beitrags:  Re: TUD-Script-Klassen: Installationsprobleme

Hallo Falk,

Danke für deine Hilfe. Nein. Ich habe nichts umbenannt. Ich habe die Schriften nochmal bestellt und sie haben sie mir sofort geschickt. Nach einem erneuten Versuch tritt der gleiche Fehler wieder auf.

Im Log steht auch:

Notwendige Dateien und Pakete werden gesucht.
Dies kann einen Moment dauern.

Datei Univers_PS.zip gefunden.
Datei DIN_Bd_PS.zip gefunden.

Grüße

Bruno

Seite 4 von 6 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/