TUD-LaTeX-Forum
http://latex.wcms-file3.tu-dresden.de/phpBB3/

Mac OS X / TexShop / Schriften werden nicht gefunden
http://latex.wcms-file3.tu-dresden.de/phpBB3/viewtopic.php?f=10&t=402
Seite 1 von 1

Autor:  NandM [ Dienstag 12. Mai 2015, 17:39 ]
Betreff des Beitrags:  Mac OS X / TexShop / Schriften werden nicht gefunden

Hallo,

ich habe das KOMA-Skript durch die Konsole gejagt und die Installation wurde abgeschlossen. Die Fonts habe ich händisch installiert und werden mir auch in der OS X Schriftenbibliothek angezeigt.

Beim Konvertieren bekomme ich jetzt folgenden Fehler in der TaxShop-Konsole (siehe Anhang)
Dieser Fehler wird dann ignoriert und es wird die normale latex Schriftart genommen.

Anscheinend kann er die Fonts nicht zuordnen, oder? Habt ihr eine Lösung für diesen Problem?

Vielen Dank
NM

Dateianhänge:
texshop ausgabe.rtf [7.36 KiB]
243-mal heruntergeladen

Autor:  tudscr [ Dienstag 12. Mai 2015, 18:11 ]
Betreff des Beitrags:  Re: Mac OS X / TexShop / Schriften werden nicht gefunden

Hallo NM,

hast du das ganze mal mit einem Minimalbeispiel kompiliert? Nimm mal bitte das folgende und poste das resultierende logfile erneut
Code:
\documentclass{tudscrreprt}
\usepackage{selinput}\SelectInputMappings{adieresis={ä},germandbls={ß}}
\usepackage[T1]{fontenc}
\begin{document}
Test
\end{document}

Was erhältst du als Ausgabe, wenn du im Terminal kpsewhich tudscr.map eingibst? Ich vermute nichts, weil
NandM hat geschrieben:
Die Fonts habe ich händisch installiert und werden mir auch in der OS X Schriftenbibliothek angezeigt.

Es macht einen Unterschied, ob du die OpenType-Variante (.ttf) oder aber die PostScript-Schriften installierst. Für letztere findest du die passenden Skripte hier (Klick).

Grüße
Falk

Autor:  NandM [ Mittwoch 13. Mai 2015, 12:19 ]
Betreff des Beitrags:  Re: Mac OS X / TexShop / Schriften werden nicht gefunden

Hallo Falk,

ich habe es jetzt nochmal Versucht mit PostScript zu installieren.

Allerdings kommt es bei der Installation zu einem Error. (siehe Rote Markierung im Anhang Teil 1)

Ich habe den Prozess weiterlaufen lassen, durch ignorieren des Fehlers. Damit kommt die Installation zum Abschluss. (siehe Anhang Teil2)

Danach habe ich den Befehl "updmap" gestartet, wie es im Hinweis steht. (siehe Output updmap)

Liegt das Problem schon bei dem Error in Teil 1 ?

vielen Dank für deine Hilfe
Narvik

Dateianhänge:
Dateikommentar: Output updmap
Konsole Output updmap.rtf [2.99 KiB]
233-mal heruntergeladen
Dateikommentar: Anhang Teil 2
Install Output Teil 2.rtf [158.02 KiB]
243-mal heruntergeladen
Dateikommentar: Anhang Teil 1
Install Oputput Teil 1.rtf [12.14 KiB]
237-mal heruntergeladen

Autor:  tudscr [ Mittwoch 13. Mai 2015, 12:57 ]
Betreff des Beitrags:  Re: Mac OS X / TexShop / Schriften werden nicht gefunden

Hallo Narvik,

das Problem ist bereits im ersten Teil zu finden. Die Dateien in den Schriftarchiven entsprechen nicht denen, die normalerweise durch das CD der TUD versendet werden (siehe die Zeile cp: uvcel___.pfb: No such file or directory\ und folgende). Wo hast du denn die Schriftarchive Univers_PS.zip und DIN_Bd_PS.zip her?

Grüße
Falk

Autor:  NandM [ Mittwoch 13. Mai 2015, 13:22 ]
Betreff des Beitrags:  Re: Mac OS X / TexShop / Schriften werden nicht gefunden

Hallo Frank,

ich habe vom Schriftenversand der Uni 2 Zips bekommen.

DIN_Mac.zip
Univers_Mac.zip

beide habe ich in das selbe Verzeichnis gepackt, in dem auch das tudscrfonts_install.sh liegt.

Allerdings sucht die Installation nach DIN_Bd_PS.zip und Univers_PS.zip (siehe Anhang)
Deshalb habe ich die .zips entsprechend umbenannt.

Möglichlicherweise ist das der Fehler. Aber wie ist der richtige Weg?

Viele Grüße
Narvik

Dateianhänge:
Font nicht gefunden.rtf [1.65 KiB]
255-mal heruntergeladen

Autor:  tudscr [ Mittwoch 13. Mai 2015, 14:49 ]
Betreff des Beitrags:  Re: Mac OS X / TexShop / Schriften werden nicht gefunden

Der richtige Weg ist es, bei der Schriftbestellung anzugeben, dass man die Schriften mit LaTeX verwenden möchte.

Autor:  NandM [ Dienstag 19. Mai 2015, 21:02 ]
Betreff des Beitrags:  Re: Mac OS X / TexShop / Schriften werden nicht gefunden

Hallo Falk,

genau das war wohl mein Problem. Mit dem richtigen Schriftenpaket läuft es jetzt.

Vielen Dank für deine Fehleranalyse!

Narvik

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/