TUD-LaTeX-Forum
http://latex.wcms-file3.tu-dresden.de/phpBB3/

Fehlerhafte PDF Lesezeichen mit bookmark
http://latex.wcms-file3.tu-dresden.de/phpBB3/viewtopic.php?f=11&t=484
Seite 1 von 1

Autor:  GoTN [ Mittwoch 30. Mai 2018, 22:07 ]
Betreff des Beitrags:  Fehlerhafte PDF Lesezeichen mit bookmark

Hallo,

ich verwende die tudscrreport Klasse mit den Paketen hyperref und bookmark.

Bei der Verwendung des Pakets "bookmark" werden die Lesezeichen in der PDF für "Abstract" und "Zusammenfassung" fehlerhaft erzeugt. Es gibt sie jeweils zwei mal, wobei ein Paar davon fehlerhaft ist.

Unten füge ich ein Beispiel an.

Hat jemand eine Idee, woran das liegen kann und wie man es beheben könnte?


Vielen Dank und viele Grüße

Code:
\documentclass[ngerman, USenglish]{tudscrreprt}
\usepackage{babel}
\usepackage{bookmark}
\usepackage{hyperref}

\title{Titel der Arbeit}
\author{Vorname Nachname}

\begin{document}
\maketitle

\TUDoption{abstract}{multiple,section}
\begin{abstract}
   English abstract.
   
   \nextabstract[ngerman]
   Deutsche Zusammenfassung
\end{abstract}

\tableofcontents
\chapter{Kapitel 1}
Inhalt.

\chapter{Kapitel 2}
\section{Abschnitt 2.1}

\end{document}         


Dateianhänge:
Dateikommentar: PDF mit fehlerhaften Lesezeichen
tudscr_bookmark.pdf [38.14 KiB]
213-mal heruntergeladen

Autor:  tudscr [ Donnerstag 31. Mai 2018, 10:27 ]
Betreff des Beitrags:  Re: Fehlerhafte PDF Lesezeichen mit bookmark

Das Problem ist bekannt und wird im nächsten Release behoben. Währenddessen kannst du dir folgendermaßen behelfen: https://github.com/tud-cd/tudscr/issues/30

Autor:  Manuel [ Freitag 24. Juli 2020, 21:16 ]
Betreff des Beitrags:  Re: Fehlerhafte PDF Lesezeichen mit bookmark

Ich bin gerade über das gleiche Problem gestolpert, allerdings mit der Version 2.06h und ansonsten aktuellen Packages.
Der Workaround funktioniert zwar, aber eigentlich sollte es ja nicht mehr auftreten, oder?

Edit: Der Originalcode von oben erzeugt bei mir den gleichen Fehler

Besten Dank im Voraus & VG
- Manuel

Autor:  tudscr [ Montag 27. Juli 2020, 12:08 ]
Betreff des Beitrags:  Re: Fehlerhafte PDF Lesezeichen mit bookmark

Ich war damals etwas voreilig, es macht ja schon einen Unterschied, ob man abstract=tocmultiple angibt oder eben nicht. Ein Fix ist raus und sollte in spätestens 48h mit v2.06i verfügbar sein.

Autor:  Manuel [ Mittwoch 29. Juli 2020, 18:29 ]
Betreff des Beitrags:  Re: Fehlerhafte PDF Lesezeichen mit bookmark

Gerade getestet; funktioniert.
Danke!

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/